Haynes Manuals Home
Results 1 to 2 of 2

Thread: Need help badly! 1993 Mercury Villager

  1. #1
    Join Date
    Jun 2008
    Posts
    2

    Unhappy Need help badly! 1993 Mercury Villager

    Okay here is the scoop.

    The speedometer is not working. Under the impression that in 09/1993 the analog speedometer for the 1993 Mercury Villager was changed (as some used part wrecker told me)...since I have a 1993 Villager he told me to look on the door at the sticker and find out when it was manufacturered..mine says 09/1992...so he gives me a part from a van that was manufactured at that time and not after 09/1993 as he says that one would not be compatible. A) is that true?

    Now here comes the slap in the face, we put the new (used) speedometer cluster into the van and it still does not work. We have supposidly lights on the unit and the fuel gauge seems to be working but still no speedometer at all. When we hook a sensor (of some sort) from the wires that would go into the cluster, everything shows a "go" but the speedometer IS STILL NOT WORKING?

    I am at a loss and have to get this van back on the road by Monday for work.
    Any suggestions or can anyone tell me what the problem is please.
    /Lace

  2. #2
    Join Date
    Jun 2008
    Posts
    2

    Default Update

    I have indeed confirmed that one needs to know if the van was manufacturered early -93 or late 93....as the part is different.

    Ours is manufacturered 09/92...still looking for help please.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •