Haynes Manuals Home
Results 1 to 2 of 2

Thread: Restoring a 1983 Mark 6

  1. #1
    Join Date
    Mar 2012
    Posts
    1

    Default Restoring a 1983 Mark 6

    Hi Guys... I have just started restoring a 1983 Mark 6 after setting in the guarage for 8 years. When it was last stored everything was running fine...However a few years back my brother tried to start the car by spraying WD40 into the intake and started a little fire!!! over the intake but put it off quickly before it did any damage to the engine.

    So Far I have replaced the tires and battery and purchased the Haynes manual for that model.

    I would like to start the engine but dont know where to start...i.e. do i change the fluids first or do I need to drain every thing including the fuel... and then go from there. I just don't want to change all fluids if the the car is not going to start and will require me to tow it to a profesional repairman.

    Would appreciate some advice...Thanks

  2. #2
    Join Date
    Jan 2007
    Posts
    4,850

    Default

    Hi Mark6,

    I would start with new fuel, as the stuff in the tank right now is almost certainly no good after sitting that long. Next, make sure the fluid levels are adequate, then try to get it running and assess what other things will have to be done. Once you've got it up and running, then it would be a good idea to replace all of the fluids.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •