Haynes Manuals Home
Results 1 to 7 of 7

Thread: 2001 JEEP Grand Cherokee Laredo 4X4 4.0 L Transmission issues.

  1. #1
    Join Date
    May 2010
    Posts
    28

    Default 2001 JEEP Grand Cherokee Laredo 4X4 4.0 L Transmission issues.

    Hello, As stated abouve I have a 2001 Jeep Grand Cherokee Laredo 4X4 4.oL with 209,600 miles on the automatic Transmission. The transmission shifts smoothly through out all the gears. I just checked the transmission fluid and it is a bright red color and maybe just a little over the top hole on the dipstick. The problem is that as I drive say with cruise on at a constant speed 50-70mph there is like a burp or a sudden jerk in the transmission the speedometer and RPn gauge drops down but the car keeps on going like nothing has happend at all. I would like to ask the brain trust here if they have an idea of what this might be. I know I can not do this work at all but before I take it the garge and get charged out the rear end I would like some idea. I do not know when or if the transmission fluid or filter has been changed or if this should be done prior to any work on it.

    thanks in advance.
    Wise Guy

  2. #2
    Join Date
    Jan 2007
    Posts
    4,850

    Default

    Hi Wise Guy,

    It doesn't sound like a fluid problem, since the fluid looks clean and the level is fine. Probably the first thing you should do is check to see if any trouble codes are stored in the PCM. There might be a transmission code, or perhaps an engine management system code that could affect the operation of the transmission.

  3. #3
    Join Date
    May 2010
    Posts
    28

    Default

    so can a regular scan tool be able to check for transmission codes? I contacted autozone and the guy said they could not check for transmisson codes. I will see if they can scan it for the managemnt codes. The check engine light is not on. What is wierd is that it shifts smoothly up and down all the gears. I hope it might be some component that can be changed out simply rather than a rebuilt transmission.

    Thanks for the follow up. If anyone else has suggestions please let me know. I have researched the other threads on this boad concerning transission issues.

    The wise guy

  4. #4
    Join Date
    Jan 2007
    Posts
    4,850

    Default

    Well, it depends on the tool. Some of the later consumer-grade tools do have the capability. Also, not all codes will turn on the check engine light. If we come across anything that matches your driveability problem, we'll post it.

  5. #5
    Join Date
    May 2010
    Posts
    28

    Default

    Thanks, will have it checked out and will let you know.

    wise Guy

  6. #6
    Join Date
    May 2010
    Posts
    28

    Default

    Well today I stopped in at Autozone to see if they can use there scan tool to check for codes. They can not check codes unless the check engine liight was on. So I dropped into Advance Autoparts and they came out and checked it and of course no codes were found. As I was driving to those two the engine died like someone just turned off the engine. maybe the transission is okay and there is a problem that turns off the engine. Anyone have any quesses? Maybe the mother board but how to detect problems with that?
    Thanks for any inofrmation.
    Wiser Guy

  7. #7
    Join Date
    May 2010
    Posts
    28

    Default

    see my other thread for the fix to this problem on my Jeep Grand Cherokee might help someone else.

    Wise Guy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •