PDA

View Full Version : Isuzu clutch



sulli1970
01-16-2008, 01:02 AM
I have an Isuzu rodeo 1995 model with a 3.2l V-6, I have replaced the clutch and put the transmission back in, when I went to put the slave cyl. back I noticed that the fork that the slave cyl. rod pushes on to engage the clutch was back against the pressure plate and I couldn't get it out even with lightly prying on it. I need to know if this can be remedied without taking the transmission back out.

admin
01-16-2008, 03:43 PM
sulli1970 - That's a drag. Try loosening the transmission to engine bolts a little and see if that will take some of the pressure off of the fork so you can move it. If that doesnt work you shouldn't have to take the trans all the way out but you will have to pull it out to get your hands in there to fix the fork.
Good luck.

sulli1970
01-23-2008, 05:14 AM
I got the tranny back out and read the Haynes manual and sort of figured it out, I got the release bearing hooked up to the lever fork and on the output shaft put the tranny up in position and couldn't get the release bearing in the pressure plate, so I loosened the pressure plate to engine bolts by turning the engine with a ratchet on the front of the crank, and well in the process of pushing it in the retaining spring came off the release bearing so I will have to pull it again. Is there any advice for putting this thing back together, it's really kicking my *** (can I say that) or ****, anyway I think you can imagine my frustration with this thing as I have been working on it for over a two months and have had it in and out four times now, so any help you can offer will be appreciated. Thanks in advance.

Lonnie

admin
01-23-2008, 03:43 PM
sulli1970 - I feel for you Lonnie. Contact us at research@haynes.com and we will get you some additional information that will help you with the installation.